Saturday, July 18, 2009

unable to startup the Resource Adapter specified in the element: location='eis/Jms/TopicConnectionFactory'

Problem: Exception occured when binding was invoked.

Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'Produce_Message' failed due to: JCA Binding Component connection issue. JCA Binding Component is unable to create an outbound JCA (CCI) connection. OrderBookingComposite:FulfillmentBatch [ Produce_Message_ptt::Produce_Message(purchaseOrder) ] : The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510 JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element The JCA Binding Component is unable to startup the Resource Adapter specified in the element: location='eis/Jms/TopicConnectionFactory'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '' element in weblogic-ra.xml has not been set to eis/Jms/TopicConnectionFactory. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution.
Solution: Add the required connection pool
Refer to the following link:
Tutorial for Running and Building an Application with Oracle SOA Suite

Monday, July 13, 2009

Error Running "populateImages" Ant Target of the Oracle FOD Infratructure Application

I wonder why my FusionOrderDemo StoreFrontModule user interface do not display the product images. I re-run the MasterBuildScript build.xml of the Infrastructure application bundled in the FusionOrderDemo_R1 and noted that the populateImages target raises an exception and that is another "timezone region not found error". I have encountered this of error before and documented it in my earlier blog but even though that I already set the appropriate "-Duser.timezone=GMT" java option on the Run properties of each of the project, the error still persisted. It seems that JDeveloper do not read the java options that I've set when the class is called from Ant.

To cut the story short, here are the steps that solved the problem:

1) Open the build. xml file @ DatabaseSchema>Resources>build.xml.

2) Replace the script of the populateImages target with the following:
<target name="populateImages" depends="compileImagesApp">
    <java classname="oracle.fodemo.share.imageloader.LoadImages" fork="true" failonerror="true" >
      <classpath refid="schema.classpath"/>
      <classpath refid="oracle.jdbc.path"/>
        <pathelement location="classes/"/>
      <arg value="${jdbc.url}"/>
      <arg value="${db.demoUser}"/>
      <arg value="${db.demoUser.password}"/>
      <arg value="${imageHome}"/>
      <jvmarg value="-Duser.timezone=GMT"/>
3) Open the ImageLoaderServiceAMImpl class @ DatabaseSchema>ApplicationSources>oracle.fodemo.share>imageloader>ImageLoaderServiceAMImpl

4) Look for something like the following code:
imagesUrl = getClass().getClassLoader().getResource(imageDirectory + subDirectory); // imagesUrl = new URL("file:///C:\\JDeveloper\\tutorial\\FusionOrderDemo_R1\\Infrastructure\\DBSchema\\Images\\thumbnails\\");

5) Comment this code: imagesUrl = getClass().getClassLoader().getResource(imageDirectory + subDirectory);

6) Uncomment this code: /
/ imagesUrl = new URL("file:///C:\\JDeveloper\\tutorial\\FusionOrderDemo_R1\\Infrastructure\\DBSchema\\Images\\thumbnails\\");

7) Replace the above directory "C:\\JDeveloper\\tutorial" with the absolute address of your directory containing the FusionOrderDemo_R1 folder.

8) Re-run the build.xml file of the MasterBuildScript project.

Tags: FusionOrderDemo_R1, JDeveloper, 11g, Fusion Order Demo

Saturday, July 11, 2009

Error Deploying to Stand Alone WebLogic Server -"java.lang.ClassNotFoundException: oracle.adf.library.webapp.ResourceServlet", "Deployment incomplete"

To avoid the following error :"java.lang.ClassNotFoundException: oracle.adf.library.webapp.ResourceServlet", deploy the application on the application context and not only on the UI project. To avoid the "Deployment Incomplete" error, try to disable proxy settings. To avoid more errors in deploying the Fusion Order Demo to a stand alone WebLogic Server 11g , refer to the following tutorial: Deploying a JDeveloper SOA Application to Oracle WebLogic Server 11g Refer also to my earlier post on - timezone region not found. Tags: JDeveloper 11g R1 WebLogic

Wednesday, July 8, 2009

Error in Running Repository Creation Utility (RCU) While Using Oracle XE database

While following the Quick Installation Guide for Oracle SOA Suite11g Release 1, I encountered the following error in running the Repository Creation Utility while using Oracle XE database.

ERROR rcu: oracle.sysman.assistants.rcu.backend.task.PrereqTask::execute: Prereq Evaluation Failed oracle.sysman.assistants.rcu.backend.validation.PrereqException: RCU-6083:Failed - Check prerequisites requirement for selected component:SOAINFRA Please refer to RCU log at C:\installers\Development\Active\rcuHome\rcu\log\logdir.2009-07-08_16-16\rcu.log for details. at oracle.sysman.assistants.rcu.backend.validation.PrereqEvaluator.executePrereqTask( at oracle.sysman.assistants.rcu.backend.task.PrereqTask.execute( at at 2009-07-08 16:34:49.848 ERROR rcu: oracle.sysman.assistants.rcu.backend.task.ActualTask::run: RCU Operation Failed oracle.sysman.assistants.common.task.TaskExecutionException: RCU-6083:Failed - Check prerequisites requirement for selected component:SOAINFRA Please refer to RCU log at C:\installers\Development\Active\rcuHome\rcu\log\logdir.2009-07-08_16-16\rcu.log for details. RCU-6107:DB Init Param Prerequisite failure for: processes Required Value = 200, Current Value = 40, Comparison Operator: ">=" at oracle.sysman.assistants.rcu.backend.task.PrereqTask.execute( at at

Run SQL Command Line
Connect as SYSDBA using user "system"
SQL> connect system/password
SQL> show parameters processes
SQL> alter system set processes=200 scope=spfile;

And dont forget to restart your database...(thanks Attila for reminding me).
For more info, see the following site: Oracle XE Tuning Tags: JDeveloper 11g R1 WebLogic SOA Suite Repository Creation Utility